Hello and welcome to our community! Is this your first visit?
Register
Results 1 to 9 of 9
  1. #1
    Flight Cadet
    Join Date
    Apr 2012
    Posts
    50
    Downloads
    0
    Uploads
    0
    Reputation Points (Add)
    0

    connecting receiver

    hi,

    I have a arduino mega ADK and i was controlling it by bluetooth now i need to connect a receiver to it.
    Can anyone show me how its done? the pins that i need to use, the libraries and how to wire it up?
    The reciever is a 6CH and the RC is a Futaba T6EXHP
    Last edited by jgrade; 06-08-2013 at 01:36 PM.

  2. #2
    Flight Cadet
    Join Date
    Apr 2012
    Posts
    50
    Downloads
    0
    Uploads
    0
    Reputation Points (Add)
    0

    Unhappy

    canĀ“t find any information about the pin connection. (the futaba is PPM)

  3. #3
    Senior Pilot wooden's Avatar
    Join Date
    Dec 2011
    Location
    Pacific Northwest
    Posts
    4,869
    Blog Entries
    1
    Downloads
    1
    Uploads
    0
    Reputation Points (Add)
    27
    My guess is your receiver only outputs pwm not ppm. PPM in your case probably has to do with the way the transmitter and receiver communicate.

    This has the pin assignments, you'll have to figure out a way to connect them if you're not using a shield: https://spreadsheets.google.com/spre...thkey=CJP8mtsF
    push the envelope, watch it bend

  4. #4
    Flight Cadet
    Join Date
    Apr 2012
    Posts
    50
    Downloads
    0
    Uploads
    0
    Reputation Points (Add)
    0
    Quote Originally Posted by wooden View Post
    My guess is your receiver only outputs pwm not ppm. PPM in your case probably has to do with the way the transmitter and receiver communicate.

    This has the pin assignments, you'll have to figure out a way to connect them if you're not using a shield: https://spreadsheets.google.com/spre...thkey=CJP8mtsF

    so i need to select witch type of Receiver in the UserConfiguration.h?
    the analog pins don't correspond to the same ones in the Arduino?
    isn't this the current pins for arduino mega? (receiver_PPM_common.h)
    Code:
    #define SERIAL_SUM_PPM_2         0,1,3,2,4,5,6,7,8,9 // ROLL,PITCH,THR,YAW... For Robe/Hitec/Futaba/Turnigy9xFrsky
    Last edited by jgrade; 06-08-2013 at 07:22 PM.

  5. #5
    Senior Pilot wooden's Avatar
    Join Date
    Dec 2011
    Location
    Pacific Northwest
    Posts
    4,869
    Blog Entries
    1
    Downloads
    1
    Uploads
    0
    Reputation Points (Add)
    27
    Again, you likely have a PWM output receiver, not a PPM one. The naming convention is confusing - PPM can be talking about either 1) the communication type between the TX and RX, or 2) the output type. If you have a PPM output type receiver, you can use the #define ReceiverPPM. You would know because it will say one of the pins on the receiver is PPM.

    Just use the "#define NormalReceiver" and connect the channels up one by one. Do not use any of the "SERIAL_SUM_PPM" choices.

    If you want to be sure of what type of receiver you have, post up what it is here, can't really tell you what you have without knowing the model #.
    push the envelope, watch it bend

  6. #6
    Flight Cadet
    Join Date
    Apr 2012
    Posts
    50
    Downloads
    0
    Uploads
    0
    Reputation Points (Add)
    0
    Quote Originally Posted by wooden View Post
    Again, you likely have a PWM output receiver, not a PPM one. The naming convention is confusing - PPM can be talking about either 1) the communication type between the TX and RX, or 2) the output type. If you have a PPM output type receiver, you can use the #define ReceiverPPM. You would know because it will say one of the pins on the receiver is PPM.

    Just use the "#define NormalReceiver" and connect the channels up one by one. Do not use any of the "SERIAL_SUM_PPM" choices.

    If you want to be sure of what type of receiver you have, post up what it is here, can't really tell you what you have without knowing the model #.
    my receiver is a COMPA X6

  7. #7
    Senior Pilot wooden's Avatar
    Join Date
    Dec 2011
    Location
    Pacific Northwest
    Posts
    4,869
    Blog Entries
    1
    Downloads
    1
    Uploads
    0
    Reputation Points (Add)
    27
    Pretty sure that does not output PPM.
    push the envelope, watch it bend

  8. #8
    Flight Cadet
    Join Date
    Apr 2012
    Posts
    50
    Downloads
    0
    Uploads
    0
    Reputation Points (Add)
    0
    receiver is a jamara compa x6
    Pretty sure that does not output PPM.
    now the only problem is the pin numbers
    Last edited by jgrade; 06-08-2013 at 09:26 PM.

  9. #9
    Flight Cadet
    Join Date
    Apr 2012
    Posts
    50
    Downloads
    0
    Uploads
    0
    Reputation Points (Add)
    0
    when i chose the "normal receiver" i get this error:
    Code:
    SoftwareSerial/SoftwareSerial.cpp.o: In function `__vector_11':
    /Applications/Arduino.app/Contents/Resources/Java/libraries/SoftwareSerial/SoftwareSerial.cpp:319: multiple definition of `__vector_11'
    AeroQuad.cpp.o:.../software/libraries/AQ_Receiver/Receiver_MEGA.h:101: first defined here
    /Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/bin/../lib/gcc/avr/4.3.2/../../../../avr/bin/ld: Disabling relaxation: it will not work with multiple definitions
    btw i am using the AeroQuadMega_v21 without a shield at all. is this right?

    isn't this the pin order? (Remote_MEGA.h)
    Code:
    #ifdef OLD_RECEIVER_PIN_ORDER
      // arduino pins 67, 65, 64, 66, 63, 62
      static byte receiverPin[6] = {5, 3, 2, 4, 1, 0}; // bit number of PORTK used for XAXIS, YAXIS, ZAXIS, THROTTLE, MODE, AUX
    #else
      //arduino pins 63, 64, 65, 62, 66, 67
      static byte receiverPin[8] = {1, 2, 3, 0, 4, 5, 6, 7}; // bit number of PORTK used for XAXIS, YAXIS, ZAXIS, THROTTLE, MODE, AUX
    #endif
    Last edited by jgrade; 06-09-2013 at 02:05 PM.


 

Similar Threads

  1. Connecting a Hobby King 2.4Ghz Receiver 6Ch
    By jamesrww in forum AeroQuad Boards & Shields
    Replies: 1
    Last Post: 03-25-2013, 05:55 AM
  2. Config not connecting
    By THC in forum AeroQuad Configurator
    Replies: 3
    Last Post: 02-07-2011, 01:14 PM
  3. Help me connecting the receiver
    By nemo4all in forum AeroQuad Tutorials
    Replies: 11
    Last Post: 06-06-2010, 09:29 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •