Hello and welcome to our community! Is this your first visit?
Register
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: AeroQuad Manual

  1. #1
    Senior Pilot wooden's Avatar
    Join Date
    Dec 2011
    Location
    Pacific Northwest
    Posts
    4,869
    Blog Entries
    1
    Downloads
    1
    Uploads
    0
    Reputation Points (Add)
    27

    AeroQuad Manual

    Seems like the manual is un-editable - I can edit any AQ wiki page that isn't in the manual, but the edit links do not show up on any page related to the manual.

    Specifically, I was going to add a link to the Typhoon frame page to the "Hardware Assembly" page, right next to the Cyclone picture/link.
    Last edited by wooden; 10-31-2012 at 09:38 AM.
    push the envelope, watch it bend

  2. #2
    Senior Pilot wooden's Avatar
    Join Date
    Dec 2011
    Location
    Pacific Northwest
    Posts
    4,869
    Blog Entries
    1
    Downloads
    1
    Uploads
    0
    Reputation Points (Add)
    27
    Also, I can't seem to get pictures posted in the right size - they're always the original size instead of being small until clicked. Help?
    push the envelope, watch it bend

  3. #3
    Administrator Airwolf's Avatar
    Join Date
    Nov 2010
    Location
    Nuremberg, Germany
    Posts
    1,027
    Downloads
    1
    Uploads
    0
    Reputation Points (Add)
    8
    Sorry, I forgot to remove the editing protection when I was testing something. Could you please try again if it works now?

    If you want to scale pictures, you can do this by adding this: [ images]Test1110.jpg|frame|none|200px[/images]

    Also I saw that you started a wiki page about the connection of various components to the AQ32 board. I think it's better to ingrate this information into the existing articles, e.g. information about connecting the receiver is already here.

  4. #4
    Senior Pilot wooden's Avatar
    Join Date
    Dec 2011
    Location
    Pacific Northwest
    Posts
    4,869
    Blog Entries
    1
    Downloads
    1
    Uploads
    0
    Reputation Points (Add)
    27
    Ah, yes, hadn't ever really delved that deep into the Manual, I'll start moving the information that isn't already gathered over.

    And thanks for the tip on the pictures, I managed to figure that out by checking the commands on the OSD wiki page.
    push the envelope, watch it bend

  5. #5
    Senior Pilot wooden's Avatar
    Join Date
    Dec 2011
    Location
    Pacific Northwest
    Posts
    4,869
    Blog Entries
    1
    Downloads
    1
    Uploads
    0
    Reputation Points (Add)
    27
    And I still can't edit the manual, as it turns out.
    Last edited by wooden; 10-31-2012 at 10:28 AM.
    push the envelope, watch it bend

  6. #6
    Administrator Airwolf's Avatar
    Join Date
    Nov 2010
    Location
    Nuremberg, Germany
    Posts
    1,027
    Downloads
    1
    Uploads
    0
    Reputation Points (Add)
    8
    I can't reproduce that issue on my side using an account with standard privs. The "Edit" tab is showing up and working as usual.

    Can you give an example page where editing doesn't work for you? What happens if you add "&do=edit" to the page's URL, e.g. "http://aeroquad.com/showwiki.php?title=Book:AeroQuad+Shields&do=edit"?

  7. #7
    Senior Pilot wooden's Avatar
    Join Date
    Dec 2011
    Location
    Pacific Northwest
    Posts
    4,869
    Blog Entries
    1
    Downloads
    1
    Uploads
    0
    Reputation Points (Add)
    27
    Well, edit button wasn't there last night, but I refreshed the page I had open and voila, there it is!
    push the envelope, watch it bend

  8. #8
    Senior Pilot wooden's Avatar
    Join Date
    Dec 2011
    Location
    Pacific Northwest
    Posts
    4,869
    Blog Entries
    1
    Downloads
    1
    Uploads
    0
    Reputation Points (Add)
    27
    Another question - how do you make text inside CODE tags a different color? On the forum you simply change the color of the text but in the Wiki, changing the color inside a CODE tag makes the color tags show up instead of changing the color. (see here)

    Sorry bout all the questions, just trying to figure this out and get the information I think the Wiki needs up there.

    Also, I think linking to two parts on one page that are named the same thing confuses the Wiki - on the Altitude Hold page, the table of contents has two "Specifications" links, one for barometer and one for sonar, but they both point to the barometer specifications.
    Last edited by wooden; 10-31-2012 at 05:47 PM.
    push the envelope, watch it bend

  9. #9
    Senior Pilot wooden's Avatar
    Join Date
    Dec 2011
    Location
    Pacific Northwest
    Posts
    4,869
    Blog Entries
    1
    Downloads
    1
    Uploads
    0
    Reputation Points (Add)
    27
    Now I see why more people don't add information to the wiki... even when you want to and put the effort in, it's not always that easy...

    I'm simply trying to add pictures to this page, but when I click the "manage attachments" button, the window that normally opens up is replaced with a blocked permissions page.

    Edit: oddly enough, it is no longer telling me my permissions are blocked. However, I can't add pictures to the wiki folder. I think this is necessary because when I paste a picture from my own folders into the editing field, it shows up as a picture instead of as an image tag. Images from the wiki folder show up as image tags. I don't know how to apply sizing, framing, etc. to the picture when it is not in text form.
    Last edited by wooden; 10-31-2012 at 07:51 PM.
    push the envelope, watch it bend

  10. #10
    Administrator Airwolf's Avatar
    Join Date
    Nov 2010
    Location
    Nuremberg, Germany
    Posts
    1,027
    Downloads
    1
    Uploads
    0
    Reputation Points (Add)
    8
    Quote Originally Posted by wooden View Post
    Another question - how do you make text inside CODE tags a different color? On the forum you simply change the color of the text but in the Wiki, changing the color inside a CODE tag makes the color tags show up instead of changing the color. (see here)
    As far as I know this is not possible with the current wiki version.

    Quote Originally Posted by wooden View Post
    Also, I think linking to two parts on one page that are named the same thing confuses the Wiki - on the Altitude Hold page, the table of contents has two "Specifications" links, one for barometer and one for sonar, but they both point to the barometer specifications.
    Yes, I noticed the same problem on other pages, but I didn't find a solution yet. Maybe with the next major upgrade of our wiki software these problems will be resolved.

    Quote Originally Posted by wooden View Post
    I'm simply trying to add pictures to this page, but when I click the "manage attachments" button, the window that normally opens up is replaced with a blocked permissions page.
    To add pictures to the wiki, don't use the Manage Attachments button. Just paste this template into the article: [images]XXX.jpg|frame|none[/images] and replace XXX with the filename, e.g. [images]Test1110.jpg|frame|none[/images] which produces the following output:


    Then just click on the link which opens the corresponding wiki page in the image namespace, e.g. this one in our example

    Then click on "Edit" there, enter a description and attach the picture with the same filename as the page! Save your changes and you're done.

    Also note that the max resolution is 1920x1200 and max filesize is ~0.5MB. Everything exceeding the limit will be scaled down, but that doesn't work really good, so better match the limits before uploading.


 
Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •