Hello and welcome to our community! Is this your first visit?
Register
Results 1 to 2 of 2
  1. #1
    New Recruit
    Join Date
    Jan 2011
    Posts
    19
    Downloads
    0
    Uploads
    0
    Reputation Points (Add)
    0

    Castle Creations Thunder Bird 18 Amp

    Has anyone had trouble with these speed controls not turning off? I am new to quads but have been in RC for a long time. I have used Castle speed controls on all types of aircraft from Trex 250 to 1/4 scale Extra. I think the problem is with the pulse from the control board don't go low enough because when the motors are not armed the output is 1000 and when you arm the motors it jumps up.

  2. #2
    Senior Pilot TCIII's Avatar
    Join Date
    Jan 2010
    Location
    North Texas
    Posts
    379
    Blog Entries
    18
    Downloads
    0
    Uploads
    0
    Reputation Points (Add)
    0
    Quote Originally Posted by dcs View Post
    Has anyone had trouble with these speed controls not turning off? I am new to quads but have been in RC for a long time. I have used Castle speed controls on all types of aircraft from Trex 250 to 1/4 scale Extra. I think the problem is with the pulse from the control board don't go low enough because when the motors are not armed the output is 1000 and when you arm the motors it jumps up.
    dcs,
    I believe that when you arm the Aeroquad controller from the transmitter, it will spin the motors at a very low speed to warn you that the motors are armed. This should be normal controller operation.
    Regards,
    TCIII


 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •