PDA

View Full Version : Nightlife from above with jittery servo



Honk
07-17-2010, 12:40 AM
I dont know why, but my compensational servo jitters in some interval of like 10 seconds, other than that the battery time significantly decreased from like 12 to 8 minutes when adding the 300 gram heavy camera and mount for it. These things puzzles me.

This is the video link: http://www.youtube.com/watch?v=TAvfE5f0AJw

And then some photos showing off the rubber bands :) I'm thinking of calling it the "RubberBandido"

pyjamasam
07-17-2010, 01:46 AM
Thats awesome looking.

What pins do you have the camera servos connected to? Are you using the Aeroquad shield? It looks like you are.

The video looks awesome. I'd love to see one from the day time. Its really hard to see the quality in the dark, but it it looks to be really really nice.
What camera did you use?

chris.

Honk
07-17-2010, 02:42 AM
Thanks!

It is an Arduino Mega at the bottom (see attached pic) with a "protoshield" on it, not the AeroQuad shield. And it uses "Wii sensors". The pitch servo is attached to pin 7 which is a HW PWM pin (in the photo only the motor pins show on 8-11). The camera servo code of 1.7.1 worked straight off but I modified it to be able to tilt/offset during flight, also I think I need to tune the sensor-angle-to-servo-value factor.

I am also gonna change the servo for another in hope that gets rid of the jitter, otherwise I'll have to spend some time by the computer...

I used a Canon IXUS 800 which did seem to handle the dark pretty good, but yes, I will put up a day video tomorrow and hopefully not pussy out on the altitude :P Can't wait till I get to a bigger field though!

I think all the rubber bands are doing the trick, but I'm still trying lots of things out. As I said I am really disappointed with the 8 minute flight time...